engine slow to pick-up

k langdon

Active Member
Joined
Jul 29, 2003
Messages
100
Location
Wiltshire
Car
1993 Mercedes E300 diesel estate
I'm a newbie to the forum.

Recently my 1998 300te 4matic has started to rumble a bit at idle and is very slow/hesitant when pressing the accelerator. It does pick-up and get going, but a lot slower than it used to.

For info, the car's been garaged and hardly used by the previous owner and the 72,000 mile service is due soon. Could it just need a good service?

Any ideas??
 

Brian WH

MB Enthusiast
Joined
Aug 21, 2002
Messages
6,283
Location
East Midlands
Car
JAGUAR XF 3.0D Premium Luxury
Don't know your model, but has it got a carburettor that has a dashpot to put oil in???? If it does it sounds as if a few drops of oil would solve your problems, just a few don't fill it.
 

andy_k

MB Enthusiast
Joined
Apr 23, 2003
Messages
5,204
Location
Bexhill, East sussex
Car
Alfa GTV 3.0
I'd suggest getting it serviced, new plugs, distributor cap, rotor arm, air filter etc will work wonders.

Alternatively once it's up and running give it a good old fashioned "Irish Service" - get on the motorway and give it a good hard run - tends to blow away any carbon and rubbish that's built up over time

Andy.
 
OP
OP
K

k langdon

Active Member
Joined
Jul 29, 2003
Messages
100
Location
Wiltshire
Car
1993 Mercedes E300 diesel estate
Thanks for the replies.

I think it probably needs a good service and a long run as suggested by Andy.
 

kth286

MB Enthusiast
Joined
Feb 4, 2003
Messages
2,923
Location
Caversham Berks
Car
E320 Coupe
perhaps it's stuck in 4 wheel drive.

any warning lights on ?

It's a fuel injected car for the poster above
 

Users who are viewing this thread

Top Bottom