Indicators come and go

tom71

Member
Joined
Dec 6, 2010
Messages
36
One min the indicators work and then they dont. I have also noticed that the hazrds will not work plus the heated rear windscreen switch will light but not stay on when i release the button, then when the indicators come back to life so does every thing else. Am i right in presuming its a relay? If so which one and where is it please? The car is an E reg w202. Thanks for all your help.

Tom
 

Messa

Active Member
Joined
Apr 9, 2004
Messages
106
Location
Wigan
Car
CLS400 Airmatic
One min the indicators work and then they dont. I have also noticed that the hazrds will not work plus the heated rear windscreen switch will light but not stay on when i release the button, then when the indicators come back to life so does every thing else. Am i right in presuming its a relay? If so which one and where is it please? The car is an E reg w202. Thanks for all your help.

Tom
Must admit, mine are on,off,on ,off !

Sorry couldnt resist.

:)
 
OP
OP
T

tom71

Member
Joined
Dec 6, 2010
Messages
36
Yea, that was my next stop with a can of contact cleaner.
 

Ted

MB Enthusiast
Joined
Feb 26, 2004
Messages
5,815
Location
Bourton on Dunsmore
Car
SLC 250D AMG Line, Yamaha XVS 1100, Jeep Renegade
I have also had one fail in the middle. It wasn't blown, it just broke at the thinnest point (prolly corrosion). Caused exactly what you are seeing
 
OP
OP
T

tom71

Member
Joined
Dec 6, 2010
Messages
36
Thinking about it, the indicator fuse and headted rear window must be on a different fuse. Very confused.
 

timk

Active Member
Joined
Aug 25, 2009
Messages
759
Location
Wiltshire
Car
VW Passat Alltrack, E39 BMW M5, Mercedes C55 AMG Wagon
Indicators not working? First thing to do is check the bonnet badge. More than likely you've accidentally bought a BMW.
 
OP
OP
T

tom71

Member
Joined
Dec 6, 2010
Messages
36
Spot on, found it behind the fuse box. It had been wedged in using cardboard, i took it out cleaned it up. Jobs a good un. Thanks once again.
 
OP
OP
T

tom71

Member
Joined
Dec 6, 2010
Messages
36
Though it could be the dreaded dry joint, just took out and resoldered the heater controls as dash board lights flashed when the lights were on. Hmmm might set up a company offering a re soldering service for these cars.
 
OP
OP
T

tom71

Member
Joined
Dec 6, 2010
Messages
36
Was dry joints in the end, all fixed.
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Top Bottom