Urgent Help with ML270CDi

Discussion in 'Engine' started by MarkF, Jul 24, 2008.

  1. MarkF

    MarkF Active Member

    Messages:
    82
    Joined:
    May 12, 2007
    Location:
    North Wales
    Car:
    ML 270CDi Silver with Cream Leather.
    I have a problem with my ML270CDi, tonight my wife drove the car up a big hill and it would not kick down. The car is ok on the flat, will kick down and go over the 2500rpm, and go over 70mph so I don’t think the car is in limp home mode, it is still hesitant to change but drives ok. The main problem is going up hill, the car lacks power, it will change with the tip function on the gearbox, drops down to second ok but I did notice the revs limited to 2500 and very little increase in speed.
    With car in park ticking over you can rev ok all the way to 5k and the turbo can be heard to whirl ok.
    Any ideas please.
     
  2. jaymanek

    jaymanek Authorised Forum Sponsor Authorised Forum Sponsor

    Messages:
    16,400
    Joined:
    Nov 29, 2002
    Location:
    Nuneaton Warwickshire
    Car:
    Lots of Mercedes!
    MAF sensor?
     
  3. Dieselman

    Dieselman Banned

    Messages:
    34,206
    Joined:
    Jul 13, 2003
    Car:
    Peugeot 403 Convertible
    It's dropped the turbo for some reason so is in limp home mode. It could be MAF, blocked Cat, stuck EGR valve or turbo actuator.
    You need the codes read really.
     
  4. OP
    OP
    MarkF

    MarkF Active Member

    Messages:
    82
    Joined:
    May 12, 2007
    Location:
    North Wales
    Car:
    ML 270CDi Silver with Cream Leather.
    Thanks for the help, the Maf was one thing I did think off, I have been chatting to a friend of mine who has a nice E class 270CDi, just had a quote from Inchcape North Wales for a D service £800 plus, he has his car booked in with these perople http://www.trefnantgarage.com/index.html
    this is where I'm going in the morning for them to have a look.

    I will post the outcome.
     
  5. panason1c

    panason1c Hardcore MB Enthusiast

    Messages:
    1,141
    Joined:
    Feb 20, 2005
    Location:
    Somerset
    Car:
    ML270cdi, VW Polo 1.9 tdi, BMW K1200rs
    Sounds like the maf to me.
     
  6. OP
    OP
    MarkF

    MarkF Active Member

    Messages:
    82
    Joined:
    May 12, 2007
    Location:
    North Wales
    Car:
    ML 270CDi Silver with Cream Leather.
    Spot on the MAF sensor was faulty, took the car to The garage at 8.30, and a new one fitted at £141. The car now runs 100% and the service was first class, the car will be going to them for all future work. A very nice S class BRABUS in the garage.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.