Becker Map Pilot

Discussion in 'Electronics' started by jiiimse, Nov 6, 2016.

  1. jiiimse

    jiiimse New Member

    Messages:
    3
    Joined:
    Aug 23, 2016
    Car:
    B Class
    Recently purchased second hand unit, when it arrived I fitted it in to my 2014 B class, and it appeared to work OK.
    I was not familiar with the controls for it, so decided to remove it until I was more familiar, and I was going on holiday
    just back from holiday, and plugged unit in, now getting message "No module fitted".

    Any advise, seeing various similar messaged on the web, but no definitive advise.

    Any help welcome.
    Is it safe to "reset" unit ?

    james:(
     
  2. Haven't a clue!

    Haven't a clue! Hardcore MB Enthusiast

    Messages:
    129
    Joined:
    Apr 3, 2016
    Location:
    Northamptonshire, UK
    Car:
    W204 C220 CDI (AMG body kit), plus BMW 320ci (E93), previously various company lease
    Suspect the reset might lose you the installed maps.
    1- have you cleaned connection s and ensured fully pressed in?
    2- Have you got the red usb cable as well? If so then suggest you google/download the Becker Manager s/w and once registered should be able to run an option to check/validate installed data.
    Cheers, Tony
     
  3. 400ixl

    400ixl Hardcore MB Enthusiast

    Messages:
    978
    Joined:
    Feb 20, 2016
    Location:
    Norfolk UK
    Car:
    E250 AMG Sport Convertible
    Any USB cable with the right connection will work, doesn't need to be anything special.
     
Tags:

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.