Car not starting. Help needed

dappz

New Member
Joined
Jul 19, 2011
Messages
5
Car
w204 c220 cdi
Hi guys.
I've got an automatic 2008 c220 cdi (w204) and it has stopped working today.
I unlocked my car and got in and put the key in and turned in and there was no power going through at all. The dash lighting didn't even light up apart from the mileage which is always displayed. The headlights don't work etc but the cd player does work so I'm confused. When I unlock the car and turn the key, the only thing that happens is that the car makes a low beeping sound for a few seconds and that's it.

Does any1 know what the problem could be?
 

Will

Hardcore MB Enthusiast
SUPPORTER
Joined
Jan 21, 2003
Messages
12,559
Location
Surrey
Car
GL63 AMG / 190E 2.5-16 / Porsche 911
Low battery?

Have you got Mobilo cover?
 
OP
OP
D

dappz

New Member
Joined
Jul 19, 2011
Messages
5
Car
w204 c220 cdi
Haven't got mobilo cover and I think the battery is alright. It seems as if some wire/solenoid might have developed a fault within/behind the keyhole barrel as there is no power there when turning the key.

Would I be correct in thinking that could be the possible cause?

Thanks
 

Will

Hardcore MB Enthusiast
SUPPORTER
Joined
Jan 21, 2003
Messages
12,559
Location
Surrey
Car
GL63 AMG / 190E 2.5-16 / Porsche 911
What makes you think the battery is alright?

You say the headlights/other lighting doesn't work?

If you're not sure how to check, best to let someone take a look or ask a garage.

When was your car registered - should be 3 year's warranty from new, not sure on the Mobilo but doesn't this get extended at service time? :)

Will
 
OP
OP
D

dappz

New Member
Joined
Jul 19, 2011
Messages
5
Car
w204 c220 cdi
I just thought the battery is ok because the cd player works and so does the central locking.
I can't move my car from the drive as it's an auto and is stuck in 'P' so I popped down to a garage and explained the problem to him and he said it sounds like the immobilizer not working but he said he would need me to get the car down to him somehow for him to check it out.

Do you think that could be the cause of it then or do you still think it might be the battery?
 

Users who are viewing this thread

Top Bottom