SL R129 speakers

Les

Member
Joined
Nov 16, 2007
Messages
42
Location
Aberdeen Scotland
Car
1997 SL60
I am looking for a replacement set of speakers for the doors on my '97 R129 SL 60.
One of the bass speakers is water damaged.
They are the 1.2ohm ones that I think were fitted to latter SL's
It looks easy enough to fit a different speaker to the housing but the ohm rating on after market speakers is usually 4 ohms.
Not my area of expertise - how do you fit the different rating and do the X-over with the smaller speaker also in the door?

Help!

Thanks
Les
 
OP
OP
L

Les

Member
Joined
Nov 16, 2007
Messages
42
Location
Aberdeen Scotland
Car
1997 SL60
Mike
thanks for the offer but the earlier ones were adifferent resistance as I understand it.

Prob easier to fit aftermarker ones in the same housing once I understand what to do about the different Ohm ratings.

Les
 

designo500

New Member
Joined
Apr 6, 2011
Messages
29
Location
North East England
Car
2007 R230 SL500
Hi,
from my interest in Hi Fi (not ipods/walkmans) I recall that that the lower the Ohm rating of a speaker design the less efficient it was at converting signal to volume. Also the more current it would demand from an amplifier. Watts per channel were not the issue but the amps ability to deliver current was/is.

Average speakers might be rated at 8ohms. Hi end Stuff like electrostatic designs might be 1 ohm and would need expensive quality amplifiers to drive them properly.

The speakers should work ok but you might have to turn the wick up more if they are less sensitive.

Hope that helps
 

Mr Nicey

Active Member
Joined
Feb 8, 2011
Messages
131
Location
Surrey
Car
SL320 V6
I replaced mine with Hertz ESL and they are better but still not much bass. I was selling the complete set from my 2000 SL 320 - still have them
 
OP
OP
L

Les

Member
Joined
Nov 16, 2007
Messages
42
Location
Aberdeen Scotland
Car
1997 SL60
Mr nicey
Interested in your speakers if they are still for sale. I saw your post but couldn't reply as I had less than 30 posts.
Are yours the 1.2 ohm type with a 4 pin square plug to connect to the loom in the door?
I can post picture if it helps.

What did you replace yours with? Was it an easy job?

Les
 

Mr Nicey

Active Member
Joined
Feb 8, 2011
Messages
131
Location
Surrey
Car
SL320 V6
I used a company in Hertfordshire who were not so good, and then had it redone by a certified installer.

It took him three hours.

It's not an easy one at all. I'll try and check the connections and get back to you.

I'm on Zero7979 Zero1Zero636 gimme a buzz

Rob
 

Users who are viewing this thread

Top Bottom