w126 560sec starting up issue

Discussion in 'Engine' started by arfan786, Aug 25, 2013.

  1. arfan786

    arfan786 Active Member

    Messages:
    135
    Joined:
    Dec 18, 2012
    Location:
    west midlands
    Car:
    mercedes benz 560 sec
    hi guys

    I need help and advice another problem which i dont need with the car i am currently trying to sort out the suspension issues on my sec. However today i am faced with a new issue with car it starts from cold no problem but after running for a while or driving and switching the car off it doesn't start up straight away for some reason?

    I was thinking it maybe an alarm or immboliser issue but that works all fine literally I have the car on for a bit switch off it doesn't start till after a good 15mins or so? :S :(

    Its cranks up but just doesn't turn over almost feels like there is no fuel going in? but strangely after a short while it decides to start up? Also what i find strange is before the car was revving high but recently its idling normal?

    I am really confused as to what i should be looking ofr i have a look under the bonnet all seems ok nothing loose no wires or cables loose etc?

    any ideas?
     
  2. DSM10000

    DSM10000 MB Enthusiast

    Messages:
    6,896
    Joined:
    Jul 12, 2011
    Location:
    Near Salisbury
    Car:
    E32O CDi Sport, MX5 1.8 Sport, RR 4.2 SC
    Sounds like a classic crankshaft position sensor problem. They often cause problems in this way before failing.
     
  3. OP
    OP
    arfan786

    arfan786 Active Member

    Messages:
    135
    Joined:
    Dec 18, 2012
    Location:
    west midlands
    Car:
    mercedes benz 560 sec
    how about fuel pump relay issue? its really puzzling?
     
  4. Skhan

    Skhan Active Member

    Messages:
    182
    Joined:
    Jan 22, 2013
    Location:
    Nottingham
    Car:
    Mercedes 500 SEC AMG Mercedes 560 SEL AMG Mercedes 320 Ce AMG Mercedes CL55 Amg Mercedes W220 Brabus
    I'd probably check out the fuel pump relay first.

    I had the same problem on a 560 that I recently sold, changed the fuel pump relay, changed the ignition control module, then the crank shaft sensor & still no luck. It must have gone to 3 different "mechanics" that all just stood there scratching their heads. It had a spark but just wouldn't fire up, I ended up having it recovered back on to my drive.

    It also left me frustrated & confused until one day I went out & brought a new set of HT leads.... It fired up straight away even though the old ones had a spark coming through
     
    1 person likes this.
  5. stwat

    stwat MB Enthusiast

    Messages:
    3,176
    Joined:
    Jun 20, 2004
    Location:
    Sheffield
    Car:
    1989 W126 300 SE
    It could br the OVP on it's way out.
     
    1 person likes this.
  6. OP
    OP
    arfan786

    arfan786 Active Member

    Messages:
    135
    Joined:
    Dec 18, 2012
    Location:
    west midlands
    Car:
    mercedes benz 560 sec
    i had little fiddle around with fuel pump relay and my suspicions are its definately the fuel pump relay.


    anyone know if these are still available from mercedes new? or anywhere else where i could buy one?
     
  7. Skhan

    Skhan Active Member

    Messages:
    182
    Joined:
    Jan 22, 2013
    Location:
    Nottingham
    Car:
    Mercedes 500 SEC AMG Mercedes 560 SEL AMG Mercedes 320 Ce AMG Mercedes CL55 Amg Mercedes W220 Brabus
    Better off looking on eBay or try the SEC SHOP in Kent, they'll defo have it
     
    1 person likes this.
  8. OP
    OP
    arfan786

    arfan786 Active Member

    Messages:
    135
    Joined:
    Dec 18, 2012
    Location:
    west midlands
    Car:
    mercedes benz 560 sec
    will give chaz a call.

    oh by the way cant really tell in your avatar picture is that a widebody sec?
     
  9. Skhan

    Skhan Active Member

    Messages:
    182
    Joined:
    Jan 22, 2013
    Location:
    Nottingham
    Car:
    Mercedes 500 SEC AMG Mercedes 560 SEL AMG Mercedes 320 Ce AMG Mercedes CL55 Amg Mercedes W220 Brabus
    will give chaz a call.

    oh by the way cant really tell in your avatar picture is that a widebody sec?[/QUOTE]

    No it's not a wide body. Yours looks very well
     
    1 person likes this.
  10. OP
    OP
    arfan786

    arfan786 Active Member

    Messages:
    135
    Joined:
    Dec 18, 2012
    Location:
    west midlands
    Car:
    mercedes benz 560 sec
    rang chaz he wants £190 for a new relay a bit steep i think.

    any ideas where else may have one?

    Skhan thanks car looks differe t to the pics now it has amg skirts and bumpers all genuine parts plus amg lip spoiler which i bought from chaz and also car now sits on amg oz splits.:thumb:
     
  11. neilrr

    neilrr MB Enthusiast

    Messages:
    6,432
    Joined:
    Jul 20, 2004
    Car:
    Various.
    Post up the part number of the FPR you are looking for.
     
  12. Skhan

    Skhan Active Member

    Messages:
    182
    Joined:
    Jan 22, 2013
    Location:
    Nottingham
    Car:
    Mercedes 500 SEC AMG Mercedes 560 SEL AMG Mercedes 320 Ce AMG Mercedes CL55 Amg Mercedes W220 Brabus
    I think I might have an old SEC coming next week (if the price is right) that I need some cosmetic bits off for mine, it runs & I won't be needing the relay. If I get it I'll be sure to let you know.... £190 is too expensive.

    Looking forward to seeing some pictures of that, you'll have to upload some.

    I've just booked mine in to get re-done. Can't wait to drive it again, it's been off the road for 6 years
     
  13. OP
    OP
    arfan786

    arfan786 Active Member

    Messages:
    135
    Joined:
    Dec 18, 2012
    Location:
    west midlands
    Car:
    mercedes benz 560 sec
    the part number is 0035452505 thats the number stamped on top of relay
     
  14. OP
    OP
    arfan786

    arfan786 Active Member

    Messages:
    135
    Joined:
    Dec 18, 2012
    Location:
    west midlands
    Car:
    mercedes benz 560 sec
    yeah let me know that will be cool. i will post some pictures of it once I get a decent camera etc and then upload vis phoitobucket.
     
  15. neilrr

    neilrr MB Enthusiast

    Messages:
    6,432
    Joined:
    Jul 20, 2004
    Car:
    Various.
    Fuel pump relays are either on or off, they don't sort of work or half work. When you turn the ignition on can you hear the fuel pump buzz? If you can then the fuel pump relay is working.

    It might have cracks in the dry joints which cause it to turn the pump off as the car is on the fly. Have you taken the cover off & either looked at the solder or just gone ahead & re-soldered the lot?
     
  16. OP
    OP
    arfan786

    arfan786 Active Member

    Messages:
    135
    Joined:
    Dec 18, 2012
    Location:
    west midlands
    Car:
    mercedes benz 560 sec
    i am pretty sure its the fuel pump relay because when i bridged the centre parts together it engages the fuel pump and cars starts fine. pins 7-8 i bridged and car started fine.
     
  17. martyz

    martyz MB Enthusiast

    Messages:
    2,395
    Joined:
    May 14, 2011
    Location:
    New Forest
    Car:
    ClK240 209,190E 201.
    You say it starts fine cold,are you bridging the FPR when the engine is warmed up? if you are you have found the fault,if you are not then you must look for a heat related cause,engine temp sensor would be my first instinct,does it smell of fuel after a hard start?
     
  18. jaymanek

    jaymanek Authorised Forum Sponsor Authorised Forum Sponsor

    Messages:
    16,412
    Joined:
    Nov 29, 2002
    Location:
    Nuneaton Warwickshire
    Car:
    Lots of Mercedes!
    FPR's on this model are a pain in the backside. Luckily I bought new ones from MB when they were still available at £30 each!

    Now they are not available at all. Although I suspect they will bring them back at multiple times the price.

    Anyway, I would change the FPR with a good one and also change the OVP with a new one from MB.
    At this age the OVP can cause all sorts of issues and should be changed as a service item IMO.
     
  19. OP
    OP
    arfan786

    arfan786 Active Member

    Messages:
    135
    Joined:
    Dec 18, 2012
    Location:
    west midlands
    Car:
    mercedes benz 560 sec
    yeah i am bridging when engine is warmed up. and also do get a smell of fule after hard start.
     
  20. OP
    OP
    arfan786

    arfan786 Active Member

    Messages:
    135
    Joined:
    Dec 18, 2012
    Location:
    west midlands
    Car:
    mercedes benz 560 sec
    hi jay

    I rang mercedes birmingham central they quoted 19+VAT but they have been on back order for a over a year.

    is there any chance you have a spare one which you could sell possibly??:D
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.