Apple CarPlay issues 2022 Vito (W447)

Page may contain affiliate links. Please see terms for details.
All in all not good Jason. Not what you expect from a relatively newly designed head unit. Seems MB got this one very wrong.

Have you managed to source a Kenwood that will work in conjunction with the MB reversing camera?
I am going to go for the 8021 as the installer said he has less issues with these integrating, although if it does cause problems he can supply and fit a compatible camera but if that is the case, i would probably go with the Alpine unit.

Sound wise, i am having fitted Audison components with a Hertz amp and fully sound proofed door shells and trims.


Also, might look into having a gearbox remap as it is currently bloody awful, unless in Sport all the time, but if you do that it kills the economy.

I know the map is designed with economy in mind and aims to get in high gear as soon as possible, but this just does not work properly, as if i am pulling away from a roundabout, turning right, it changes up whilst going round and when you then want to accelerate to make progress, it then decides to drop a gear. Similar happens on approach to a right hand turn into a side road, especially if you just need to slow down to take the turning and not come to a stop. You turn in and then accelerate and its too dumb to have changed down ready and when it does, it jolts you into a lower gear. Does my feckin head in.
 
I am going to go for the 8021 as the installer said he has less issues with these integrating, although if it does cause problems he can supply and fit a compatible camera but if that is the case, i would probably go with the Alpine unit.

Sound wise, i am having fitted Audison components with a Hertz amp and fully sound proofed door shells and trims.


Also, might look into having a gearbox remap as it is currently bloody awful, unless in Sport all the time, but if you do that it kills the economy.

I know the map is designed with economy in mind and aims to get in high gear as soon as possible, but this just does not work properly, as if i am pulling away from a roundabout, turning right, it changes up whilst going round and when you then want to accelerate to make progress, it then decides to drop a gear. Similar happens on approach to a right hand turn into a side road, especially if you just need to slow down to take the turning and not come to a stop. You turn in and then accelerate and its too dumb to have changed down ready and when it does, it jolts you into a lower gear. Does my feckin head in.
Agree and understand the above regarding auto.

There’s far too many gripes for a £+42k vehicle.

I’ve actually popped in another transit order. 👍
 
Thanks for that Alfie.

It bothers me a lot. I can go to multiple addresses per day. Having no navigation is a pest, especially on a brand new (expensive?) van on which I fully expect Apple CarPlay to work perfectly (as it’s done on all my previous (non MB vehicles).

I can’t see how Apple can be at fault as my phone works perfectly on every system in every other car. It’s certainly something with the Vito system.
I have the same problem with a Vito 2022 model. To cut a long story v short none of the software upgrades have sorted the problem and I have also had a replacement head unit which was as useless as the original! Merc are aware of the problem and there is now a MODIFIED head unit (ie different hardware) which looks exactly the same and solves the problem. Alas though it is on back order as there are none in the Uk or in Germany and Marshalls Croydon can't give me a date when they expect to get a unit and fit it!!!
 
I have the same problem with a Vito 2022 model. To cut a long story v short none of the software upgrades have sorted the problem and I have also had a replacement head unit which was as useless as the original! Merc are aware of the problem and there is now a MODIFIED head unit (ie different hardware) which looks exactly the same and solves the problem. Alas though it is on back order as there are none in the Uk or in Germany and Marshalls Croydon can't give me a date when they expect to get a unit and fit it!!!
Hello there.

Funny you post today as MB Carlisle phoned yesterday to say the replacement items have arrived on site and have booked me in for fitting on Saturday 14th October. It was ordered through the TIPS case the suppling dealer raised with MB in Germany.

We shall see. 🫣
 
For reference guys this is a unit that works 100% and hasn’t disconnected once whilst it was fitted for a couple months with twice and sometimes more daily use.

I posted it a few pages ago so some may have missed it.

Software version : 6.30
Daimler Software Version: 22/42.02
Daimler Software Part Number: A447 902 84 14
Daimler Hardware Version: 22/14.00
Daimler Hardware Part Number: A447 901 67 08

Might be of use to someone!
 
Hello there.

Funny you post today as MB Carlisle phoned yesterday to say the replacement items have arrived on site and have booked me in for fitting on Saturday 14th October. It was ordered through the TIPS case the suppling dealer raised with MB in Germany.

We shall see. 🫣
That is exactly what has happened with me via the TIPS case. Incidently the manager of Marshalls Croyden drove a 2022 model for 2 weeks with an iphone 13 and had the same problems but now has a 2023 model with same head unit but hardware modified and works flawlessly. The latest 2024 model year has a different head unit completely. So hopefully your modified unit will work flawlessly. I have to say that I think Mercedes have behaved disgracefully in not having a recall to install the modified unit in all 2021 and 2022 model year vitos.
 
For reference guys this is a unit that works 100% and hasn’t disconnected once whilst it was fitted for a couple months with twice and sometimes more daily use.

I posted it a few pages ago so some may have missed it.

Software version : 6.30
Daimler Software Version: 22/42.02
Daimler Software Part Number: A447 902 84 14
Daimler Hardware Version: 22/14.00
Daimler Hardware Part Number: A447 901 67 08

Might be of use to someone!
Have you had the upgraded/modified unit fitted or is your unit the original as supplied?
 
…… I have to say that I think Mercedes have behaved disgracefully in not having a recall to install the modified unit in all 2021 and 2022 model year vitos.

TOTALLY agree. They’ve known about the issue for such a long time and didn’t seem to rush to produce a solution. Not very ‘premium brand’ is it? Maybe the commercial department isn’t so important to them.

Another issue came to light last week. It seems the 13 pin tow bar socket doesn’t have a permanent Live. So it’s not charging my tipping trailer as I tow. Another thing to sort. 😤
 
TOTALLY agree. They’ve known about the issue for such a long time and didn’t seem to rush to produce a solution. Not very ‘premium brand’ is it? Maybe the commercial department isn’t so important to them.

Another issue came to light last week. It seems the 13 pin tow bar socket doesn’t have a permanent Live. So it’s not charging my tipping trailer as I tow. Another thing to sort. 😤
Should be on pin 9 shouldn't it?
Edit - should also be a switched live on 10
 
Have you had the upgraded/modified unit fitted or is your unit the original as supplied?

That’s what the van came with from the factory in June this year MY 03/23 I believe.

I’ve ripped it out and installed a pioneer now and it is sooooooo much better as I couldn’t stand the stupid bright screen at night with no way of adjusting it to a sensible level, and the appalling sound quality.
 
That’s what the van came with from the factory in June this year MY 03/23 I believe.

I’ve ripped it out and installed a pioneer now and it is sooooooo much better as I couldn’t stand the stupid bright screen at night with no way of adjusting it to a sensible level, and the appalling sound quality.
I believe that pioneer make the original unit for mercedes!!
 
Should be on pin 9 shouldn't it?
Edit - should also be a switched live on 10
Indeed. But there’s neither.

Funny thing is that there’s a 12 core flex going into the plug. (No.12 is a spare). Seems odd to have it wired for all functions but not active. 🤷‍♂️

I (wrongly) assumed that the battery in my trailer was at fault. So fitted a new battery 3 months ago (old one was the original).

New one gradually went flat and that’s when the penny dropped that it wasn’t getting charged. 🫣
 
Have you had the upgraded/modified unit fitted or is your unit the original as supplied?

For reference guys this is a unit that works 100% and hasn’t disconnected once whilst it was fitted for a couple months with twice and sometimes more daily use.

I posted it a few pages ago so some may have missed it.

Software version : 6.30
Daimler Software Version: 22/42.02
Daimler Software Part Number: A447 902 84 14
Daimler Hardware Version: 22/14.00
Daimler Hardware Part Number: A447 901 67 08

Might be of use to someone!
Interesting. My 2022 Van has the floowing

Sofware version: 6.30
Daimler Software Part Number : A447 902 84 14
Daimler Harware Version: 21/08.00
Daimler Hardware Part Number: A447 901 70 07

Same Software as your Van but different Hardware version and Part numbers so hopefully the modified unit that will be fitted to my van may cure the issue for me and hopefully everyone else with the same problem.
 
I believe that pioneer make the original unit for mercedes!!


Maybe in the past but the Vito currently uses a unit made by Garmin.

Saw some pics of the 2024 Vito and it looks so much more improved.

Options potentially include:
Mbux and digital dash
Multi beam led headlights.
Updated front end.
Etc.

One thing that is mildly amusing is the dimmed load lighting for loading at night. WTF?

You can barely see with the load light as it is!



 
Last edited:
Indeed. But there’s neither.

Funny thing is that there’s a 12 core flex going into the plug. (No.12 is a spare). Seems odd to have it wired for all functions but not active. 🤷‍♂️

I (wrongly) assumed that the battery in my trailer was at fault. So fitted a new battery 3 months ago (old one was the original).

New one gradually went flat and that’s when the penny dropped that it wasn’t getting charged. 🫣
I wonder if it's been coded correctly?
 
I wonder if it's been coded correctly?
Well. It was a hefty factory fit option so I expect them to rectify. Unless they say it was never meant for charging in which case a 7 pin socket should have been fitted.

I can see me having to pay an auto electrician to find and connect the other end. 😑
 
TOTALLY agree. They’ve known about the issue for such a long time and didn’t seem to rush to produce a solution. Not very ‘premium brand’ is it? Maybe the commercial department isn’t so important to them.

There was a problem with the crank position sensor on all OM642 V6s built within a certain date range and MB UK did a safety recall for all models ... apart from the W639. Mine was affected (the engine stopped dead and wouldn't fire at all) - out of warranty so I had to pay for a mobile tech. to come out and diagnose/fix. Asked MB for a goodwill payment (owned from new, FMBSH) and got nowhere.

Another issue came to light last week. It seems the 13 pin tow bar socket doesn’t have a permanent Live. So it’s not charging my tipping trailer as I tow. Another thing to sort. 😤

That's quite common on MBs - the factory towbar wiring on my W639 had no permanent or switched live supplies. I lived with it for some years till I got a caravan with an AL-KO anti-snake system that needed the permanent live.
 
There was a problem with the crank position sensor on all OM642 V6s built within a certain date range and MB UK did a safety recall for all models ... apart from the W639. Mine was affected (the engine stopped dead and wouldn't fire at all) - out of warranty so I had to pay for a mobile tech. to come out and diagnose/fix. Asked MB for a goodwill payment (owned from new, FMBSH) and got nowhere.
That must have been frustrating Bill. Such a common story unfortunately. Corporate greed once again.
That's quite common on MBs - the factory towbar wiring on my W639 had no permanent or switched live supplies. I lived with it for some years till I got a caravan with an AL-KO anti-snake system that needed the permanent live.
Well that’s that then eh. I’ll fully expect to sort a permanent Live out myself.

Seems bizarre how they’ve used a 12 core cable going into the socket but not bothered to make certain connections at the other end!

A mate has a new transit custom with a factory 13 pin socket. Charges his tipping trailer beautifully. 🙄
 
Seems bizarre how they’ve used a 12 core cable going into the socket but not bothered to make certain connections at the other end!

My factory 13 pin socket didn't even have connectors in it for the switched live and corresponding earth (10 & 11):

1695678477335.png

The one above is the permanent live (9) ... that had a connector that just wasn't connected to anything! Apparently some generations of ML were the same from the factory, and others had all the connections present & correct. As you say, bizarre!
 
I’ll be a year next week since I took delivery of the van. Yesterday morning I paid a visit to the dealership in Carlisle (8th time) to have the new head unit module fitted regarding the CarPlay issue. It seems to have worked as the half hour journey home was faultless maintaining a hard wired connection. I’ll monitor it this coming week before I start celebrating.

They also changed the faulty TPMS valve on the FNS wheel. ✅

Booked in again next Saturday to investigate the lack of permanent live on the 13 pin socket. (The suppling dealer has confirmed that there should be one for charging after he got advice from MB tech team).

Annoying to be still having issues a year on but at least they’re being sorted.

Hopefully next week should be the last visit. 🤞
 

Users who are viewing this thread

Back
Top Bottom