C63 coupe - acceleration clicking

AndyJT

New Member
Joined
Oct 15, 2015
Messages
3
Car
C63
Afternoon All,
New member here, I have been a member of a few forums in the past and about 4 months ago I purchased my dream car. A C63 coupe which I wanted for years after hearing the pace car at Silverstone in 2010. Turning to my mate at the time saying "I need that noise in my life".:thumb:

I've done about 5000 miles since taking ownership and loving the drive & attention it gets. Spent 2k so far on servicing, fixing a problem and tyres.

Love the car but have had a few issues, the gearbox had developed a leak due to a missing clamp & bolt which Merc sorted quite quickly. I have noticed there seems to be a clicking when I accelerate hard. If I accelerate hard a second successive time it doesn't happen but leave it 5 mins and happens again. It doesn't happen if the engine is reved standing still. Really strange. I'm a bit lost with this one and have searched the threads on here but can't find anything. Has anyone got any ideas?
 

GazzyFizzle

Active Member
Joined
Jul 28, 2015
Messages
172
Location
UK
Car
None
It could be 'pinking', these cars need running on super unleaded minimum.

Try filling up with V-Power/98+ RON fuel, and give it a few days, and see how it is.

P.S. Nice car, I have a black one :)
 

aquanaut

Active Member
Joined
Jun 22, 2009
Messages
767
Location
Aberdeen, Scotland
Car
2019 C43 AMG Estate
Welcome to the forum, nice car. Yes defo super unleaded. Run it on v power for a few tanks
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Top Bottom