W211 E320cdi springs/shocks shot or blame the bad roads?

kdh

Active Member
Joined
Oct 3, 2013
Messages
170
Car
E Class 320cdi Estate
Gentlemen,

Took my E Class Estate four-up on a run yesterday and couldn't help but thinking that the ride had got firmer since I bought it 3 years ago.

149,000 miles and by the look of the full MB history it's never had any suspension needed. Tyres are all good and balanced.

Should I blame it on the worsening roads or would my springs/shocks be a bit tired now and need replacing?

It used to 'waft' more over most bad road surfaces but you can feel the bumps more now, although there are no untoward noises, creaks, rattles, knocks etc. All sounds lovely and smooth.

Many thanks for any advice as usual.
 

DSM10000

MB Enthusiast
SUPPORTER
Joined
Jul 12, 2011
Messages
7,998
Location
Near Salisbury
Car
E32O CDi Sport, MX5 1.8 Sport, RR 4.2 SC
Gentlemen,

Took my E Class Estate four-up on a run yesterday and couldn't help but thinking that the ride had got firmer since I bought it 3 years ago.

149,000 miles and by the look of the full MB history it's never had any suspension needed. Tyres are all good and balanced

It used to 'waft' more over most bad road surfaces but you can feel the bumps more now, although there are no untoward noises, creaks, rattles, knocks etc. All sounds lovely and smooth.

.

Have you had any MOT advisories about springs or dampers?

If you are running on original springs and dampers then they will certainly not be working as well as when new.

If you intend to keep the car it would be a worthwhile investment, buy parts from MB, you know they will match perfectly, MB springs are colour coded to your vehicle specification when new.:thumb:
 
OP
OP
K

kdh

Active Member
Joined
Oct 3, 2013
Messages
170
Car
E Class 320cdi Estate
If you are running on original springs and dampers then they will certainly not be working as well as when new.

Thanks, but do you think I'd notice the difference if I changed them? (No advisories btw)
 

DSM10000

MB Enthusiast
SUPPORTER
Joined
Jul 12, 2011
Messages
7,998
Location
Near Salisbury
Car
E32O CDi Sport, MX5 1.8 Sport, RR 4.2 SC
Thanks, but do you think I'd notice the difference if I changed them? (No advisories btw)

I am sure you would, you say yourself that the ride quality has diminished

Suspension components have to be seen as service items that wear out.
 
OP
OP
K

kdh

Active Member
Joined
Oct 3, 2013
Messages
170
Car
E Class 320cdi Estate
Thanks very much.
 

CL1210

New Member
Joined
Jul 21, 2013
Messages
11
Location
Coventry
Car
E350
My apologies if this is in the wrong thread.
As you all know i have been having a rear issue with my W211 for quite some time now. Right so i normally get a dud -dud -dud (kind of noise) when i go through uneven road surface or over speed humps. the noise is from the rear left (passenger side) of the car. Its been up the ramps to check nothing obvious i can see to be the cause. The car rides kinda weird in the rear suspension i.e. not comfortable and very unstable.
The following has been done since the discovery of the noise 6-7 months ago:
*Drivers side rear spring broken (Replaced with stock from dealer both L&R)
*Left rear shock slight misting from top (Replaced both L&R with Bilstein B4 bought from a site in Germany recommended by another forum member Codger49) the shocks were A1.
*Last resort was to replace the all 4 rear sub frame bushes after searching the forum (Got them from dealer, though most indys said they hardly go wrong but i still got them replaced. And to be fair the ones on the car were still solid no signs of wear or tear, but i got them replaced anyway in a hope that the car will change or ride better.

While on the ramps the cars rear suspension was checked (allegedly).

To my surprise the noise is still there and the car is unstable on the rear suspension you can feel it when go over uneven road surface or small potholes or even corners at certain speeds.

*The rear tyres are Good Year Eagle F1 not run flats (255/35/18) which i changed from Pirelli P-Zero (245/45/18)

*Fronts have always been (245/40/18)

I have mentioned the tyre sizes on here as am so confused i dont know what to do now, am not enjoying this car anymore as i used to. Surely after replacing all these the car should feel really nice just like out of a show room kind of.

Please anyone here help me on this one please. what am i missing?
 

coneybiller

Active Member
Joined
May 11, 2016
Messages
206
Location
Cheltenham
Car
S210 320cdi Avantgarde 02'
My apologies if this is in the wrong thread.
As you all know i have been having a rear issue with my W211 for quite some time now. Right so i normally get a dud -dud -dud (kind of noise) when i go through uneven road surface or over speed humps. the noise is from the rear left (passenger side) of the car. Its been up the ramps to check nothing obvious i can see to be the cause. The car rides kinda weird in the rear suspension i.e. not comfortable and very unstable.
The following has been done since the discovery of the noise 6-7 months ago:
*Drivers side rear spring broken (Replaced with stock from dealer both L&R)
*Left rear shock slight misting from top (Replaced both L&R with Bilstein B4 bought from a site in Germany recommended by another forum member Codger49) the shocks were A1.
*Last resort was to replace the all 4 rear sub frame bushes after searching the forum (Got them from dealer, though most indys said they hardly go wrong but i still got them replaced. And to be fair the ones on the car were still solid no signs of wear or tear, but i got them replaced anyway in a hope that the car will change or ride better.

While on the ramps the cars rear suspension was checked (allegedly).

To my surprise the noise is still there and the car is unstable on the rear suspension you can feel it when go over uneven road surface or small potholes or even corners at certain speeds.

*The rear tyres are Good Year Eagle F1 not run flats (255/35/18) which i changed from Pirelli P-Zero (245/45/18)

*Fronts have always been (245/40/18)

I have mentioned the tyre sizes on here as am so confused i dont know what to do now, am not enjoying this car anymore as i used to. Surely after replacing all these the car should feel really nice just like out of a show room kind of.

Please anyone here help me on this one please. what am i missing?

I'm having very similar issues with my W210 estate at the mo. I've just had all of the rear multi link arms replaced. It now creaks and feels very crashy and unstable when going over bumps. I actually nearly lost it in a 50mph contraflow section of the M4 yesterday, after crossing the central reservation area following the lane, I went over a grate and the back end went all squirrely and a lot of correction had to take place to keep it in a straight line! Unnerving is an understatement! Had the car up on a ramp since the arms were replaced, but cannot see anything obvious! All bolts are tight and all seems present and correct! I need to get an alignment carried out and go from there I think!

How was the alignment on your W211? did it need any adjustment?
 

Users who are viewing this thread

Top Bottom