[SOLVED] W221 S-Class Whooshing Sound

Discussion in 'Engine' started by Kay187, Jul 19, 2017.

  1. Kay187

    Kay187 Member

    Messages:
    55
    Joined:
    Aug 31, 2012
    Location:
    Scotland
    Car:
    S-class 320 CDI
    Hi,

    I've recently noticed a loud whooshing sound coming from the left hand side of the engine bay when accelerating around 3000 revs. The car pulls fine and no issues with performance but the sound is rather concerning. I looked around the forums and seen the intercooler pipe as being a possible cause but my usual mechanic can't see any issues there.

    Also anyone recommend any decent Indys in the Glasgow southside area? Anyone used MB Jarvie? I want my codes read off a Star machine. I've had a front battery changed but still have a few electrical gremlins so want to see if anything comes up.

    Thanks!
     
  2. MancMike

    MancMike New Member

    Messages:
    0
    Joined:
    Jul 29, 2014
    Ah yes, that'd be the sound that all S-Classes make as you surge past the paupers. :thumb:
     
  3. OP
    OP
    Kay187

    Kay187 Member

    Messages:
    55
    Joined:
    Aug 31, 2012
    Location:
    Scotland
    Car:
    S-class 320 CDI
    Haha that has a more authoritative tone to it...
     
  4. zipdip

    zipdip Hardcore MB Enthusiast

    Messages:
    2,494
    Joined:
    Mar 5, 2015
    Location:
    Essex
    Car:
    s320
    Well my S320 if it was pulling 3000 revs in top gear would be doing over 100mph,I suppose you mean as you accelerate,it depends on how heavy footed you are but my bet would be the turbo,with regard making this noise as you pass paupers,I have no idea as I never look at the lowly cars I pass.
     
  5. OP
    OP
    Kay187

    Kay187 Member

    Messages:
    55
    Joined:
    Aug 31, 2012
    Location:
    Scotland
    Car:
    S-class 320 CDI
    Sorry yes I meant as I'm accelerating from standstill or when overtaking. My initial thoughts were turbo (God forbid!) but as the performance of the car is fine with no lag or anything I'm assuming the turbo is fine? Having said that I do see the odd white smoke from the exhaust which may or may not be related.
     
  6. whitenemesis

    whitenemesis MB Club Veteran

    Messages:
    15,980
    Joined:
    May 7, 2007
    Car:
    Lexus RC300h F-Sport 2019
    Whooshing sound in my 203 was a split pipe, not immediately obvious.
     
  7. OP
    OP
    Kay187

    Kay187 Member

    Messages:
    55
    Joined:
    Aug 31, 2012
    Location:
    Scotland
    Car:
    S-class 320 CDI
    I'm thinking the same so think I need a 2nd opinion, which pipe was split on your car?
     
  8. whitenemesis

    whitenemesis MB Club Veteran

    Messages:
    15,980
    Joined:
    May 7, 2007
    Car:
    Lexus RC300h F-Sport 2019
    No idea, sorry. Dealer found and replaced under warranty. Would have cost £120 for the part..
     
  9. OP
    OP
    Kay187

    Kay187 Member

    Messages:
    55
    Joined:
    Aug 31, 2012
    Location:
    Scotland
    Car:
    S-class 320 CDI
    I managed to get this sorted ;)

    There appeared to be a loose (intake? not sure what it's called) pipe near the turbo.

    [​IMG]

    Once I pushed this firmly in, the noise disappeared as far as I can tell so far.

    Now to get the codes read and sort the electrical gremlins in the car....
     
    Last edited: Jul 25, 2017

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.