The Complete M271 Engine thread. ( Revised and Updated )

Discussion in 'Engine' started by R2D2, May 15, 2010.

  1. Jedburglives

    Jedburglives New Member

    Messages:
    6
    Joined:
    Dec 31, 2013
    Location:
    Portishead
    Car:
    SLK 200K Auto
    Timing belt tensioner failure

    Hi R2D2, am reading your very detailed thread on the M271 engine. My wife has an SLK 200, 2005 model (R171) which I think is the M271 engine.

    The car has been fully maintained and serviced by Mercedes. It has only 77k on the clock and typically does about 50 miles a day.

    After hearing a strange noise we took it to Mercedes and they then discovered that the belt was loose and more or less ate most of the cam teeth.

    I think that in the 2006 model the tensioner was updated but as you see from my terminology above, I am not too F A with whats happened. I need to understand what the issue was with the poly tensioners and where I can find more info as part of our argument to get Mercedes to cover the costs.

    Can you provide any info to help us.

    Thanks
     
  2. grober

    grober MB Club Veteran

    Messages:
    27,221
    Joined:
    Jun 22, 2003
    Location:
    Perth, Scotland
    Car:
    W204 C200CDI Estate
    The M271 engine has a timing chain not a belt. It does have an external poly V belt which drives all the ancilliaries- alternator/power steering/aircon compressor /waterpump-- it also has a tensioner/jockey wheel Are you referring to the timing chain which drives the camshafts? or the poly v belt? I suspect you mean the timing chain?????
     
  3. Jedburglives

    Jedburglives New Member

    Messages:
    6
    Joined:
    Dec 31, 2013
    Location:
    Portishead
    Car:
    SLK 200K Auto
    Chain yes, my fault. The timing chain that drives the camshaft was loose. It was explained to me that the tensioner auto adjusts to keep the chain tight but that the tensioner failed and made the chain loose. I was told that the tensioner was a poly type. The mercedes dealer works estimates mentions that the camshaft adjustment limits have been reached upon inspection. Does this help?
     
  4. grober

    grober MB Club Veteran

    Messages:
    27,221
    Joined:
    Jun 22, 2003
    Location:
    Perth, Scotland
    Car:
    W204 C200CDI Estate
    My guess is that this means the camshaft sprockets [ gears] will also need replacing as well as the timing chain /tensioner / guides. If that is the case the sensible course is to rebuild the entire timing gear at the front of the engine. Timing chain and associated problems are pretty common on these engines.
     
  5. grober

    grober MB Club Veteran

    Messages:
    27,221
    Joined:
    Jun 22, 2003
    Location:
    Perth, Scotland
    Car:
    W204 C200CDI Estate
  6. Koolvin

    Koolvin Administrator Staff Member

    Messages:
    10,076
    Joined:
    Jun 1, 2002
    Location:
    Staines
    Car:
    W168, W169 & S202
    Thread made a sticky.
     
  7. georgehifi

    georgehifi New Member

    Messages:
    7
    Joined:
    Jul 1, 2015
    Car:
    2006 C200 coupe
    Hi, I'm new and maybe buying my 3rd MB today, a 2006 C200 2 door coupe with 90km on the clock.

    Used Mercedes-benz C200 for Sale | CarsGuide

    What sort of other things should I look for beside what's below?

    All the ones that I have looked at so far have had quite strong blow by from the oil filler when opened while idling, is this normal as all have done it so far, even with higher or lower k's.

    Thanks for any advice
    Cheers George
     
  8. grober

    grober MB Club Veteran

    Messages:
    27,221
    Joined:
    Jun 22, 2003
    Location:
    Perth, Scotland
    Car:
    W204 C200CDI Estate
    These are mainly forced induction engines with lots of bypass plumbing pipes and valves and venting. These tend to malfunction/degrade with age so I expect crankcase pressurisation is fairly normal. Provided there is no major mechanical engine noise when cold and when warmed up and the engine warning light illuminates on switch on and extinguishes on engine start and remains off after a prolonged test drive you should be fine. This thread should furnish you with the main things to look for.
     
  9. dshishman

    dshishman New Member

    Messages:
    2
    Joined:
    Nov 20, 2015
    Car:
    W211
    Useful thread
     
  10. Viruslover

    Viruslover New Member

    Messages:
    3
    Joined:
    Sep 1, 2015
    Car:
    W211 E200K 2005 123' km
    hello.

    does my 2005 E200 kompressor m271 use a returnless fuel pressure system? is my fuel pressure regulator inside my fuel filter, near the rear wheel outside the gas tank?

    i have hard starts after car has cooled down to semi-warm, and cold idle is a bit weird. hot idle can move around very very slightly if i look at the tachometer but it usualy sits at 900.

    and its using more fuel than earlier. usually 8,5 liters /100 km on highway driving. when i got my car at 107000 km after plug n airfilter service it used 6,7L / 100 km on highway

    thinking of changing the filter if the fuel pressure regulator is inside to see if that helps.

    air filter and plugs was replaced 15000 km ago but the hard semi ward start and gas use has been worse and worse since last summer.
     
  11. grober

    grober MB Club Veteran

    Messages:
    27,221
    Joined:
    Jun 22, 2003
    Location:
    Perth, Scotland
    Car:
    W204 C200CDI Estate
    I would be looking at your fuel tank venting system to see if its choked. You may be pulling a partial vacuum in your tank which effects fuel supply.
    The fuel tank on later cars is quite complex on the w203 its plastic/twopart and mounted under the rear seats. It has a main pump and transfer pump to make sure each half of the tank is emptied- I can't speak for the W211which is an earlier design.
     
    Last edited: Feb 14, 2016
  12. ceoby

    ceoby New Member

    Messages:
    1
    Joined:
    Jun 13, 2016
    Car:
    w211 200 k
    Hi R2D2,
    I really like how you have check all possible options to improve this engine with different options from the market. I have read all the pages but I can't find the solutions. You have mention in one of your post that you have chip tuning your engine and was fine with more response and a lower consumption but no extra HP. At the end I didn't find clear if the kit from Kleemann who looks good on paper has some real advantage on dyno. Ex:
    1. Kleemann Headers.
    2. Kleemann Boost Kit.
    3. Kleemann Ecu upgrade.
    4. Kleemann Exhaust with kit.

    I have an w211 200 K and I was very disappointed that Mercedes in the last years didn't improve our engine software or anything else. Always I have asked for some software updates upgrades during the service cycle but nothing. I really like the car and I still found w212 and f10 to expensive around 20.000€ or more. So I would like to know if any chip tuning can make something real good for car like increase the engine efficiency or performance or if Kleemann worth to "improve" the car.
    Thanks.
     
  13. henrywashere

    henrywashere New Member

    Messages:
    1
    Joined:
    Oct 11, 2016
    Car:
    CLK 200
    Replacing M271 engine in my CLK 200

    Hi,

    New member here and don't have the most technical knowledge so seeking some help!!

    I am needing to replace the engine in my 2003 CLK 200 and am struggling to find the exact M271 engine variant (M271.940.30.080791), I was wondering if anyone could confirm that other variants; specifically M271.946 usually fitted in C180 or C200K models would fit.

    I know the main difference is Turbocharger vs. Supercharger but as long as they are still compatible and engine mounts are the same then that will do!

    Any advice or knowledge on this will be greatly appreciated!! :thumb:

    Thanks,

    Henry
     
  14. simonjamesturne

    simonjamesturne Active Member

    Messages:
    72
    Joined:
    Aug 6, 2006
    Location:
    Berkshire
    Car:
    E270cdi
    EVO variants

    Does anyone know if the EVO versions of the M271 with the inverted tooth timing chain still suffer from chain stretching, or has the change cured the problem?
     
  15. ajey

    ajey New Member

    Messages:
    2
    Joined:
    Jan 2, 2017
    Car:
    CLK 200
    Hello to all.

    I have a 2003 CLK 200 kompressor with a problem, when runningin in idle for 15 to 30 sec. it turns 1 of cylinder of ( I think is the first one ). I have change almost all of sensors and it still isn't fixed :wallbash: . MB ppl are all saying that they need to remove top of the engine and test the valves, but I don't think that is the best way, and that they are only to get more money of me...
    On diagnostic test it said something like "not enough pressure in cylinder 1" )

    The car has 140k km and it was maintained at the highest possible standards.

    I was reading that this models have problem with oil in the wiring loom.

    Can anyone help me with some ideas what is wrong?

    Thank you.:rock:
     
  16. markjay

    markjay MB Club Veteran

    Messages:
    23,807
    Joined:
    Jun 24, 2008
    Location:
    London
    Car:
    W204 C180 Executive SE 2013 Automatic / COMAND NTG4.7 and Morel speakers fitted by www.comand.co.uk
    A good old compression test should be able to spot a leaky valve I would have thought?

    Regarding the oil-in-loom issue, remove the two electrical connectors from the camshaft position sensors at the front of the engine and check for any oil around the seals or inside the connector housing. If oil travels all the way up to the ECU, it can cause various issues, but loss of cylinder compression is not one of them.
     
  17. ajey

    ajey New Member

    Messages:
    2
    Joined:
    Jan 2, 2017
    Car:
    CLK 200
    But it only turns off the first cylinder when engine is in idle and when I turn off the engine and on again, it works on all 4, but if I'm idling for 15 or more seconds it turns off first cylinder again.
     
  18. ernie

    ernie Hardcore MB Enthusiast

    Messages:
    437
    Joined:
    Apr 3, 2006
    Location:
    Scotland East
    Car:
    C Class, W205 Sport 2018
    Have a search on the other UK forum, but there have been problems with gear wear on some cars fitted with the 'inverted tooth chain'. The sight of filings in a gutted oil filter doesn't give a lot of confidence that the problems are resolved.

    Having said that one only sees the problems on forums and if the car you want is quiet when idling or starting, that is good reassurance.

    Ernie
     
  19. Milz1912

    Milz1912 New Member

    Messages:
    1
    Joined:
    Jan 22, 2017
    Car:
    Mercedes Benz C180k W203
    I drive a c180k, 2003 W203 and would want to convert it into a c32amg, however, cheaper c32amg salvage vehicles are all left hand drive. Can I still use the same engine, gearbox, drivetrain from the LHD version in my RHD version
     
  20. nicolson

    nicolson New Member

    Messages:
    3
    Joined:
    Jan 24, 2018
    Location:
    cz
    Car:
    04 e200 kompressor
    Hello guys, I'm having a strange problem.. I have an 04 E200 kompressor (m271.941) and the car has some problem when running in open loop. After cold start it has almost no power (I have problems to reverse out of the garage), misfires and smells too rich. Everything goes fine after it goes to closed loop. I would say the problem started after I got some low quality fuel from shell and my fuel pump slowly died - the car didn't start few times. I have changed the fuel pump and fuel filter assembly and now I can start the car without any problems, but the problem with open loop remained. I was thinking of fuel injectors being dirty but if it was the injectors it wouldn't get any better in closed loop? Just for being curious I bought some injector cleaner and poured it into the tank but it doesn't seem to help. I have checked the problematic vaccum hose (only the one under the airbox) and it seems to be in a good condition. I also checked the coolant and intake temperature reading with my obd scanner and didn't find any issue, I cleaned the throttle and replaced spark plugs without any success, too. Do you have any idea on whats wrong?
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.